Gemalto is now part of the Thales Group, find out more.

You are here

TC65i-X: AT^SJOTAP - Download of Jad fails | Thales IoT Developer Community

February 27, 2015 - 12:34pm, 3727 views

Hi there!

it seems to me that AT^SJOTAP fails if the Web-Servers Response for downloading the Jad-File doesn't contain a Content-Length (but contains "Transfer-Encoding": chunked instead) .

Error-Code 906 or AT^SJOTAP blocks after connecting:

[OTAP] GPRS connection established.

[OTAP] Try to get http://dtag.cumulocity.com/inventory/binaries/418589501 ...

[OTAP] Connected.
^SYSSTART


have a look a the  Webserver-Header:

$ curl  -v --proxy <IP>:8080 --header "Authorization: Basic <authstring>" <URL-to-Jad> -O

*   Trying <IP>...

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current

                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0* Connected to <IP>(<IP>) port 8080 (#0)

> GET <URL-to-Jad> HTTP/1.1

> User-Agent: curl/7.40.0

> Host: <Host>

> Accept: */*

> Proxy-Connection: Keep-Alive

> Authorization: Basic <authstring>

>

< HTTP/1.1 200 OK

< Server: nginx

< Date: Fri, 27 Feb 2015 09:51:15 GMT

< Content-Type: text/plain; charset=UTF-8

< Transfer-Encoding: chunked

< Content-Disposition: attachment; filename="S6C8Y.jad"

< Cache-Control: proxy-revalidate

< Proxy-Connection: Keep-Alive

< Connection: Keep-Alive

< Age: 0


Am I right in assuming that might be the reason for the failing Download?

(on other webservers the AT^SJOTAP works well for the same Jad/Jar-File

here the server-response looks a tad different:

==================== Jad - Apache-Coyote/1.1 ===================

Access-Control-Allow-Origin: *

Access-Control-Allow-Methods: POST, GET, OPTIONS, DELETE

Access-Control-Max-Age: 3600

Access-Control-Allow-Headers: x-requested-with

X-Content-Type-Options: nosniff

X-XSS-Protection: 1; ****=block

Cache-Control: no-cache

Pragma: no-cache

Expires: Thu, 01 Jan 1970 00:00:00 GMT

X-Frame-Options: DENY

Cache-Control: no-store

Content-Disposition: attachment; filename=S6C8Y.jad

Content-Type: text/plain;charset=UTF-8

Content-Length: 503

Connection: close 16:21) 

How can I solve this problem - keeping in mind I'm not the Webservers-Administrator?

Cheers!
Marko