Gemalto is now part of the Thales Group, find out more.

You are here

^SIS: 0,0,13,"The network is unavailable" loop with ELS61-E | Thales IoT Developer Community

July 31, 2018 - 9:35am, 2780 views

Hello,

we have Problems with ELS61-E where after a successfull connect, the module always throws "^SIS: 0,0,13,"The network is unavailable". We currently react to such errors by shutting down the module (even the supply voltage is disabled and enabled again) and start it again. In the shown case the behaviour continued for over one hour. Only after a manual reset of the whole board a succesfull communication could be established.

This issue occured several ***** but, we were not able to reproduce it repeatable.

What could be the reason for such behaviour?

AT-Command Sequence:

ATE0

ATE0

^SYSLOADING

ATE0

ATE0

 

OK

AT+CMEE=1

OK

AT+CGMI

Cinterion

OK

 

AT+CGMM

ELS61-E

OK

 

AT+CGMR

REVISION 01.000

OK

 

AT+CCID

+CCID: *****

OK

 

AT+CIMI

*****

OK

 

AT+CPIN?

+CPIN: READY

OK

 

AT+CEREG?

+CEREG: 0,0

OK

 

AT+CGREG?

+CGREG: 0,4

OK

 

AT+CREG?

+CREG: 0,0

OK

 

^SYSSTART

 

AT+CEREG?

+CEREG: 0,0

OK

 

AT+CGREG?

+CGREG: 0,4

OK

 

AT+CREG?

+CREG: 0,0

OK

  

AT+CEREG?

+CEREG: 0,0

OK

 

AT+CGREG?

+CGREG: 0,4

OK

 

AT+CREG?

+CREG: 0,1

OK

 

AT+CGATT?

+CGATT: 0

OK

 

AT+CGATT?

+CGATT: 0

OK

AT+CGATT=1

OK

AT+CGATT?

+CGATT: 1

OK

 

AT^SICS=0,"conType","GPRS0"

OK

AT^SICS=0,"apn","*****"

OK

 

AT^SICS=0,"user","<USER>"

OK

AT^SICS=0,"passwd","<PWD>"

OK

 

AT+CGPADDR=1

 +CGPADDR: 1,"0.0.0.0"

OK

 

AT+CGREG?

 +CGREG: 0,1

OK

AT^SISS=0,"srvType","socket"

OK

AT^SISS=0,"conId",0

OK

AT^SISS=0,"address","sockudp://*****:*****;port=*****"

OK

AT^SISS=0,"tcpMR",10

OK

AT^SISO=0

OK

AT^SISI=0

^SISI: 0,3,0,0,0,0

OK

 

^SISW: 0,1

AT^SISI=0

^SISI: 0,4,0,0,0,0

 OK

AT^SISW=0,291

^SISW: 0,291,0

OK

 

^SISW: 0,1

^SISR: 0,1

AT^SISR=0,1152

^SISR: 0,18

OK

AT^SISR=0,1152

^SISR: 0,0

OK

 

^SIS: 0,0,13,"The network is unavailable"

 

^SISR: 0,2

AT^SISW=0,983

+CME ERROR: 3

AT^SISC=0

OK

AT^SMSO

 ^SMSO: MS OFF

 OK

^SHUTDOWN

 

<DISABLE_VIA_ENABLE_PIN>

<ENABLE_VIA_ENABLE_PIN>

<CONTINUE FROM BEGINNING>

Best regards,

Sebastian