Thales' cellular IoT products business is now part of Telit Cinterion, find out more.

You are here

Running or Debugging on an EHS5T with Netbeans 8.2 | Telit Cinterion IoT Developer Community

August 31, 2017 - 9:45am, 1906 views


for a customer project, I am currently trying to set up a development environment to develop Java ME MIDlets for the EHS5T.

I have used the "setup.exe" on the Install CD, to set everything up (Drivers, MES IMPDebugConnection, WTK and so on...) The setup was very straighforward and everything seemed to be integrated nicely into Netbeans. I the opened the HelloWorld example project and tried to run it. It even connected the "IP connection for remote debugging of EHSx" and set an IP address, but then the connection ***** out.

Using COM5 I can send AT commands and I am also able to install the built jar and jad file of the HelloWorld from the FFS and run it. No Problem. But an Execution or Debugging from inside Netbeans is not possible at all.

I have consulted the "ehsx_java_usersguide_v07 " and double-checked everything, mentioned in chapter 10 "Compile and Run a Program with a Java IDE". Still no success. But after consulting the document "EHS5_startup_guide_v04" I am starting to wonder: Debugging etc. possible at all, when just using the EHS5T device? (Not the EHS5 evaluation module and also no DSB75 or DSB-Mini) Or is the DSB75 (or DSB-Mini) mandatory for this?

My Setup:

  • Windows 7 32-Bit (SP1 with all recent updates)
  • Gemalto EHSx Software Development Kit installled through "setup.exe" on install cd
  • Netbeans 8.2 with Java ME and Mobility Tools installed
  • EHS5T connected via USB

If this is of any interest, here is my AT^SCFG-Output:

^SCFG: "Audio/Loop","0"
^SCFG: "Call/Ecall/AckTimeout","5000"
^SCFG: "Call/Ecall/Callback","0"
^SCFG: "Call/Ecall/CallbackTimeout","43200000"
^SCFG: "Call/Ecall/Msd","0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000"
^SCFG: "Call/Ecall/Pullmode","0"
^SCFG: "Call/Ecall/SessionTimeout","20000"
^SCFG: "Call/Ecall/StartTimeout","5000"
^SCFG: "Call/ECC","0"
^SCFG: "Call/Speech/Codec","0"
^SCFG: "Gpio/mode/ASC1","std"
^SCFG: "Gpio/mode/DAI","gpio"
^SCFG: "Gpio/mode/DCD0","gpio"
^SCFG: "Gpio/mode/DSR0","gpio"
^SCFG: "Gpio/mode/DTR0","gpio"
^SCFG: "Gpio/mode/FSR","gpio"
^SCFG: "Gpio/mode/PULSE","gpio"
^SCFG: "Gpio/mode/PWM","gpio"
^SCFG: "Gpio/mode/RING0","gpio"
^SCFG: "Gpio/mode/SPI","rsv"
^SCFG: "Gpio/mode/SYNC","std"
^SCFG: "GPRS/AutoAttach","enabled"
^SCFG: "Ident/Manufacturer","Cinterion"
^SCFG: "Ident/Product","EHS5-E"
^SCFG: "MEopMode/Dormancy","0","0"
^SCFG: "MEopMode/SoR","off"
^SCFG: "MEShutdown/Fso","0"
^SCFG: "MEShutdown/sVsup/threshold","0","0"
^SCFG: "Radio/Band","147"
^SCFG: "Radio/OutputPowerReduction","4"
^SCFG: "Serial/Interface/Allocation","1","1"
^SCFG: "Serial/USB/DDD","0","0","0409","1E2D","0058","Cinterion Wireless Modules","EHx",""
^SCFG: "Tcp/IRT","3"
^SCFG: "Tcp/MR","10"
^SCFG: "Tcp/OT","6000"
^SCFG: "Tcp/WithURCs","on"
^SCFG: "Trace/Syslog/OTAP","0"
^SCFG: "Userware/Autostart","0"
^SCFG: "Userware/Autostart/Delay","0"
^SCFG: "Userware/DebugInterface","","","0"
^SCFG: "Userware/DebugMode","on"
^SCFG: "Userware/Passwd",
^SCFG: "Userware/Stdout","file","10000","a:/test.log","buffered","off"
^SCFG: "Userware/Watchdog","0"


Thank you very much for your help in advance!