Gemalto is now part of the Thales Group, find out more.

You are here

PLS8-E - Data connection issue through USB | Thales IoT Developer Community

June 3, 2015 - 1:32pm, 4563 views

Hello,

I'm trying to connect to data network through USB port of my PLS8-E with command ATD*99***1#, but the module send me a CME error : +CME ERROR: phone adaptor link reserved . It works fine through the serial port ASC0 on DSB-mini + DSB75 adaptator.

Why ?

In details, here is my hardware config :
DSB-mini :
 - Serial switch ASC0 on RS232 (I would like to send AT commands through ASC0 while the module is connected on the USB port).
 - 12VDC power supplied.

AH6 - DSB75 Adaptor - 1 :
 - 4G sim inserted. 
 - Mini-Usb connector plugged to my PC : Gemalto M2M PC driver (2.0.8.42) correctly installed, AT communication is Ok (through Gemalto M2M ALSx PLSx USB CDC-ACM Port 1 ).
 - Jumpers are at the same position then specified into the ALS3_PLS8_startup_guide_v01 (Appendix on DSB75).

PLS8-E :
 - Revision 02.011
 - Signal - CSQ : 21,99
 - Registered (PIN active and correct) : E-UTRAN **** (+COPS: 0,0,"BEL PROXIMUS",7).
(no specific configuration yet, this is an "out-of-the-box" test).

Here is some information that could be useful :

3/06/2015 12:09:39.42 [RX] - at^scfg?<CR>

^SCFG: "Audio/Loop","0"<CR><LF>
^SCFG: "Audio/SvTone","0"<CR><LF>
^SCFG: "Call/ECC","0"<CR><LF>
^SCFG: "Call/Speech/Codec","0"<CR><LF>
^SCFG: "GPRS/Auth","2"<CR><LF>
^SCFG: "GPRS/AutoAttach","enabled"<CR><LF>
^SCFG: "MEop****/DTM/****","1"<CR><LF>
^SCFG: "MEop****/ExpectDTR","current","acm1","acm2","acm3","acm4"<CR><LF>
^SCFG: "MEop****/ExpectDTR","powerup","acm1","acm2","acm3","acm4"<CR><LF>
^SCFG: "MEop****/FastDormancy/****","Off"<CR><LF>
^SCFG: "MEop****/FastDormancy/Timer","5"<CR><LF>
^SCFG: "MEop****/NonBlock/Cops","0"<CR><LF>
^SCFG: "MEop****/PowerMgmt/LCI","disabled"<CR><LF>
^SCFG: "MEop****/PwrSave","enabled","0","50"<CR><LF>
^SCFG: "MEShutdown/OnIgnition","off"<CR><LF>
^SCFG: "MEShutdown/Timer","off"<CR><LF>
^SCFG: "Misc/CId",""<CR><LF>
^SCFG: "Radio/Band","2928787"<CR><LF>
^SCFG: "Radio/CNS","0"<CR><LF>
^SCFG: "Radio/Mtpl","0"<CR><LF>
^SCFG: "Radio/OutputPowerReduction","4"<CR><LF>
^SCFG: "SMS/AutoAck","0"<CR><LF>
^SCFG: "URC/DstIfc","app"<CR><LF>
^SCFG: "URC/Ringline","local"<CR><LF>
^SCFG: "URC/Ringline/ActiveTime","10"<CR><LF>
<CR><LF>
OK<CR><LF>

3/06/2015 13:17:25.26 [RX] - AT&V<CR>

<CR><LF>
ACTIVE PROFILE:<CR><LF>
E1 Q0 V1 X1 &C1 &D2 &S0 \Q3<CR><LF>
S0:000 S3:013 S4:010 S5:008 S6:002 S7:000 S8:002 S10:014<CR><LF>
+CBST: 0,0,1<CR><LF>
+CRLP: 61,61,48,6,0<CR><LF>
+CRLP: 61,61,48,6,1<CR><LF>
+CRLP: 240,240,52,6,2<CR><LF>
+CR: 0<CR><LF>
+CRC: 0<CR><LF>
+CMGF: 0<CR><LF>
+CSDH: 0<CR><LF>
+CNMI: 0,0,0,0,1<CR><LF>
+IPR: 115200<CR><LF>
+CMEE: 2<CR><LF>
+CSMS: 0,1,1,1<CR><LF>
^SLCC: 0<CR><LF>
^SCKS: 0,1<CR><LF>
^SSET: 0<CR><LF>
+CREG: 0,1<CR><LF>
+CLIP: 0<CR><LF>
+CAOC: 1<CR><LF>
+COPS: 0,0,""<CR><LF>
+CGSMS: 1<CR><LF>
<CR><LF>
OK<CR><LF

Thank you for your help.

Regards.

Vincent.