Gemalto is now part of the Thales Group, find out more.

You are here

Not possible to use debugging with EHS8 | Thales IoT Developer Community

March 8, 2017 - 7:46pm, 3036 views

Hello,

I'm starting working on an EHS8 module (with a DSB75 and Multi-Adapter R1 boards). I work under Win7 32 bits SP1.

I only tested the HelloWorld example provided with the development kit. When I try to use the debugger in Eclipse, I've got the following error message like many people before me it seems :

Using USB port COM13.

Connecting to module...

Initializing module for debugging...

Establishing "IP connection for remote debugging of EHSx"...

Registering ip address "192.168.244.1" of remote debugging device...

Waiting for debug device registration of "IMP_NG_EHS5_REMOTE"...

Passing control to external device emulator...

Failed to connect remote debugging device!

End of debug session. Emulator is closed!

The configuration of my module is as follow:

ati1

Cinterion

EHS8

REVISION 03.001

A-REVISION 00.000.14

OK

at^scfg?

^SCFG: "Audio/Loop","0"

^SCFG: "Call/ECC","0"

^SCFG: "Call/Speech/Codec","0"

^SCFG: "GPRS/AutoAttach","enabled"

^SCFG: "Gpio/****/ASC1","gpio"

^SCFG: "Gpio/****/DAI","gpio"

^SCFG: "Gpio/****/DCD0","std"

^SCFG: "Gpio/****/DSR0","std"

^SCFG: "Gpio/****/DTR0","std"

^SCFG: "Gpio/****/FSR","gpio"

^SCFG: "Gpio/****/GPSANT","gpio"

^SCFG: "Gpio/****/HSIC","gpio"

^SCFG: "Gpio/****/PULSE","gpio"

^SCFG: "Gpio/****/PWM","gpio"

^SCFG: "Gpio/****/RING0","gpio"

^SCFG: "Gpio/****/SPI","rsv"

^SCFG: "Gpio/****/SYNC","gpio"

^SCFG: "Ident/Manufacturer","Cinterion"

^SCFG: "Ident/Product","EHS8"

^SCFG: "MEShutdown/Fso","0"

^SCFG: "MEShutdown/sVsup/threshold","0","0"

^SCFG: "MEopMode/CFUN","0","1"

^SCFG: "MEopMode/SoR","off"

^SCFG: "Radio/Band","511"

^SCFG: "Radio/Mtpl","0"

^SCFG: "Radio/OutputPowerReduction","4"

^SCFG: "Serial/Interface/Allocation","0","0"

^SCFG: "Serial/USB/DDD","0","0","0409","1E2D","0058","Cinterion Wireless Modules","EHx",""

^SCFG: "Tcp/IRT","3"

^SCFG: "Tcp/MR","10"

^SCFG: "Tcp/OT","6000"

^SCFG: "Tcp/WithURCs","on"

^SCFG: "Trace/Syslog/OTAP","0"

^SCFG: "URC/Ringline","local"

^SCFG: "URC/Ringline/ActiveTime","2"

^SCFG: "Userware/Autostart","1"

^SCFG: "Userware/Autostart/Delay","0"

^SCFG: "Userware/DebugInterface","192.168.244.1","192.168.244.2","0"

^SCFG: "Userware/DebugMode","on"

^SCFG: "Userware/Passwd",

^SCFG: "Userware/Stdout","usb4",,,,"off"

^SCFG: "Userware/Watchdog","0"

OK

I've been through all the threads I could find on this forum about a similar problem and I've tried all the proposed solutions:

  • The ****m is correctly configured on COM13
  • I can send AT commands to the module on COM13
  • The terminal window using COM13 has been closed before launching the debugger
  • The firewall has been disabled
  • I have tried to uninstall/reinstall everything without success
  • I have tried with several version of Eclipse and with Netbeans

Would you have additional advice to try to solve this problem?

Regards,

Benoit