Thales' cellular IoT products business is now part of Telit Cinterion, find out more.

You are here

No output of NEMA sentences with PLS8-E | Telit Cinterion IoT Developer Community

August 15, 2019 - 3:00pm, 1708 views


i have an embedded linux device using a PLS8-E modem for LTE and GPS. LTE works fine, but I cannot seem to get anything out of the GNSS tty.

I have enabled the NEMA output following the description in the AT command reference document (the one for non aided mode for now). I use the service set 2. The current state of the GNSS is as follows:


^SGPSC: "Engine","1"

^SGPSC: "Info","Urc","off"

^SGPSC: "Nmea/Freq",1

^SGPSC: "Nmea/Glonass","on"

^SGPSC: "Nmea/DeadReckoning","off"

^SGPSC: "Nmea/DRSync","off"

^SGPSC: "Nmea/Output","buffered"

^SGPSC: "Nmea/Urc","off"

^SGPSC: "Power/Antenna","on"


This seems to look fine to me. I tried to get any output on /dev/ttyACM2 using microcom but I got nothing. I have tried various bit rates as I have not found any information on the bit rate that is used for /dev/ttyACM2.

I would appreciate any hints that would allow me to proceed here. Thank you very much.

PS: I was also wondering what the NEMA output would look like if I have no reception. Does it report in intervals that it does not have a fix?