Thales' cellular IoT products business is now part of Telit Cinterion, find out more.

You are here

IllegalArgumentException Socket-Error:3??? | Telit Cinterion IoT Developer Community

July 12, 2020 - 6:56pm, 1294 views


This is a follow-up to a recent post where I received some feedback, but unfortunately the replies have not solved my problem.

I am using a BGS5T (USB) terminal to POST data to a server via HTTPS. I post data once per minute and every so often (approx. once in every 20-30 posts) I get a ^SIS: 1,0,8002,"HttpHTTP POST: IllegalArgumentException Socket-Error:3" when I complete my post with AT^SISW=1,0,1.

I am confident that the terminal initialisation process is correct because the POST operation works for 85% of the time.

I cannot find any description of this error anywhere in the documentation and the problem is that when the error occurs the module is completely locked from the point in time of the post and until the error is generated - this being a period of 2-3 minutes. During this period the only method to send commands is to power the modem down and then back-up again.

To the best of my knowledge the IllegalArgumentException Socket-Error:3 is network related, but I might be wrong.

I have plenty of signal (-80dBm) and I have tried various SIM cards in the BGS5T and all seem to result in the same problem. I have also tried the SIM cards in a USB stick, selected the same network and made calls to the same server and this works reliably.

My application requires high connection reliability and as such this problem represents an issue.

Does anyone have any experience of HttpHTTP POST: IllegalArgumentException Socket-Error:3?

Thanks in advance...