Gemalto is now part of the Thales Group, find out more.

You are here

EHS6 debugging in Eclipse/NetBeans doesn't work | Thales IoT Developer Community

November 13, 2017 - 2:19pm, 5817 views

Hello, 

I am trying to setup everything so I can debug the program in eclipse or netbeans, but after running the setup and following instructions I feel like I missed something. I get this message in Eclipse.

Connecting to module...

Initializing module for debugging...

Establishing "IP connection for remote debugging of EHSx"...

Registering ip address "192.168.244.1" of remote debugging device...

Waiting for debug device registration of "IMP_NG_EHS5_REMOTE"...

Passing control to external device emulator...

Failed to connect remote debugging device!

End of debug session. Emulator is closed!

I'm not sure how to make it work. I had the same problem with BGS5 terminal. Anyway, here's the AT^SCFG  of the EHS6 

at^scfg?

^SCFG: "Call/ECC","0"

^SCFG: "GPRS/AutoAttach","enabled"

^SCFG: "Gpio/mode/ASC1","gpio"

^SCFG: "Gpio/mode/DAI","gpio"

^SCFG: "Gpio/mode/DCD0","std"

^SCFG: "Gpio/mode/DSR0","std"

^SCFG: "Gpio/mode/DTR0","std"

^SCFG: "Gpio/mode/FSR","gpio"

^SCFG: "Gpio/mode/HSIC","gpio"

^SCFG: "Gpio/mode/PULSE","gpio"

^SCFG: "Gpio/mode/PWM","gpio"

^SCFG: "Gpio/mode/RING0","gpio"

^SCFG: "Gpio/mode/SPI","rsv"

^SCFG: "Gpio/mode/SYNC","gpio"

^SCFG: "Ident/Manufacturer","Cinterion"

^SCFG: "Ident/Product","EHS6"

^SCFG: "MEShutdown/Fso","0"

^SCFG: "MEopMode/SoR","off"

^SCFG: "Radio/Band","511"

^SCFG: "Radio/OutputPowerReduction","4"

^SCFG: "Serial/Interface/Allocation","1","1"

^SCFG: "Serial/USB/DDD","0","0","0409","1E2D","0058","Cinterion Wireless Modules","EHx",""

^SCFG: "Tcp/IRT","3"

^SCFG: "Tcp/MR","10"

^SCFG: "Tcp/OT","6000"

^SCFG: "Tcp/WithURCs","on"

^SCFG: "Trace/Syslog/Otap","0"

^SCFG: "URC/Ringline","local"

^SCFG: "URC/Ringline/ActiveTime","2"

^SCFG: "Userware/Autostart","1"

^SCFG: "Userware/Autostart/Delay","0"

^SCFG: "Userware/DebugInterface","0.0.0.0","0.0.0.0","0"

^SCFG: "Userware/DebugMode","on"

^SCFG: "Userware/Passwd",

^SCFG: "Userware/Stdout","usb1",,,,"off"

^SCFG: "Userware/Watchdog","0"

Turning off the firewall didn't help either. I'll be thankful for any help. 

Regards,

Kábrt.