Gemalto is now part of the Thales Group, find out more.

You are here

Cannot establish remote debugging to ELS81 | Thales IoT Developer Community

March 25, 2020 - 2:40pm, 884 views

Hello,

I am trying to esablishe debug session over USB to ****m (ELS81) always getting theses errors 

Using USB port COM3.

Connecting to module...

Initializing module for debugging...

Establishing "IP connection for remote debugging of ELSx"...

Registering ip address "192.168.244.1" of remote debugging device...

Waiting for debug device registration of "IMP_NG_ELSx_REMOTE"...

Passing control to external device emulator...

Failed to connect remote debugging device!

*** Error ***

Device "IMP_NG_ELSx_REMOTE1" not registered!

End of debug session. Emulator is closed!

- I checked firwall settings on Win 10 and the Jave SE has all connections allowed the OJMEE is stable and running 

here is my SCFG settings:

^SCFG: "GPRS/AutoAttach","enabled"

^SCFG: "Gpio/****/ASC1","gpio"

^SCFG: "Gpio/****/DCD0","gpio"

^SCFG: "Gpio/****/DSR0","gpio"

^SCFG: "Gpio/****/DTR0","gpio"

^SCFG: "Gpio/****/FSR","gpio"

^SCFG: "Gpio/****/PULSE","gpio"

^SCFG: "Gpio/****/PWM","gpio"

^SCFG: "Gpio/****/RING0","gpio"

^SCFG: "Gpio/****/SPI","gpio"

^SCFG: "Gpio/****/SYNC","gpio"

^SCFG: "Ident/Manufacturer","Cinterion"

^SCFG: "Ident/Product","ELS81-E"

^SCFG: "MEShutdown/Fso","0"

^SCFG: "MEShutdown/sVsup/threshold","0","0"

^SCFG: "MEopMode/CFUN","0","1"

^SCFG: "MEopMode/CregRoam","0"

^SCFG: "MEopMode/ExpectDTR","current"

^SCFG: "MEopMode/ExpectDTR","powerup"

^SCFG: "MEopMode/RingOnData","off"

^SCFG: "MEopMode/SoR","off"

^SCFG: "MeOpMode/SRPOM","0"

^SCFG: "Radio/Band/2G","0x00000014"

^SCFG: "Radio/Band/3G","0x00000081"

^SCFG: "Radio/Band/4G","0x08080085"

^SCFG: "Radio/Mtpl/2G","0"

^SCFG: "Radio/Mtpl/3G","0"

^SCFG: "Radio/Mtpl/4G","0"

^SCFG: "Radio/OutputPowerReduction","4"

^SCFG: "Serial/Interface/Allocation","0","0"

^SCFG: "Serial/USB/DDD","0","0","0409","1E2D","005B","Cinterion Wireless Modules","ELSx",""

^SCFG: "Tcp/IRT","3"

^SCFG: "Tcp/MR","10"

^SCFG: "Tcp/OT","6000"

^SCFG: "Tcp/WithURCs","on"

^SCFG: "Trace/Syslog/OTAP","0"

^SCFG: "Urc/Ringline","local"

^SCFG: "Urc/Ringline/ActiveTime","2"

^SCFG: "Userware/Autostart","1"

^SCFG: "Userware/Autostart/Delay","0"

^SCFG: "Userware/DebugInterface","192.168.244.1","192.168.244.2","0"

^SCFG: "Userware/DebugMode","on"

^SCFG: "Userware/Passwd",

^SCFG: "Userware/Stdout","usb2",,,,"off"

^SCFG: "Userware/Watchdog","0"

OK

img1

img2

img3