Gemalto is now part of the Thales Group, find out more.

You are here

Cannot communicate with BGS2-T via RS232 | Thales IoT Developer Community

Bas's picture
Bas

March 16, 2021 - 9:31am, 674 views

Hello,

I have a bgs2t modem and I aqm trying to communicate with it via rs232. I am NOT using a rs232/usb converter and I am using a working cable since it works with another modem device. I used putty with configuration 9600,7,even,1,xon/xoff  (the one who sold me the modem told me to use this). I have also used other configurations like 9600,8,none,1 and others, but no way I can communicate.

The putty console stays black and when I press keys nothing happens. I cannot send any AT commands. The modem registers itself on the carrier network since the orange LED blinks 3s off/75ms on, but after that it looks like dead.

I have read on this forum that voltage on IGN_IN pin might be the cause, so I have tried to give a voltage between pins PLUS and GND only but the result is the same.

 

A lot of users on this forum had a problem similar to mine and they solved it. How can I try?