Gemalto is now part of the Thales Group, find out more.

You are here

BGS2T - CSD data connection is not working | Thales IoT Developer Community

November 13, 2018 - 12:12pm, 1201 views

We have a BGS2T modem with CSD SIM card, however we could not connect to another modem via CSD.

In the tests performed we can see the "RING" "RING" .... and then it appears in the  NO CARRIER.

I send below the modem settings:

at&v

ACTIVE PROFILE:

E0 Q0 V1 X4 &C1 &D0 &S0 \Q0 

S0:001 S3:013 S4:010 S5:008 S6:000 S7:060 S8:000 S10:002 S18:000 

+CBST: 7,0,1

+CRLP: 61,61,78,6 

+CR: 0 

+FCLASS: 0 

+CRC: 0

+CMGF: 0

+CNMI: 0,0,0,0,1

+ICF: 3

+ILRR: 0

+IPR: 9600

+CMEE: 0

^SMGO: 0,0

+CSMS: 0,1,1,1

^SACM: 0,"000000","FFFFFF"

^SLCC: 0

^SCKS: 0,1

^SSET: 0

+CREG: 0,1

+CLIP: 0,2

+CAOC: 0

+COPS: 0,0,"P OPTIMUS"

+CGSMS: 3

AT^SCFG?

^SCFG: "Audio/AMR","enabled"

^SCFG: "Audio/Loop","0"

^SCFG: "Call/ECC","0"

^SCFG: "Call/SpeechVersion1","0"

^SCFG: "GPRS/ATS0/withAttach","on"

^SCFG: "GPRS/AutoAttach","disabled"

^SCFG: "GPRS/RingOnIncomingData","off"

^SCFG: "MEop****/CregRoam","0"

^SCFG: "PowerSaver/****9/Timeout","20"

^SCFG: "Radio/Band/HandOver","0"

^SCFG: "Serial/Ifc","0"

^SCFG: "Tcp/IRT","3"

^SCFG: "Tcp/MR","10"

^SCFG: "Tcp/OT","6000"

^SCFG: "Tcp/WithURCs","on"

^SCFG: "URC/CallStatus/CIEV","restricted"

^SCFG: "URC/CallStatus/SLCC","verbose"

^SCFG: "URC/Datamode/Ringline","off"

^SCFG: "URC/Ringline","local"

^SCFG: "URC/Ringline/ActiveTime","2"

Can you check if there is any wrong parameter for this type of connection?

Kinds Regards,

Ricardo Pinho