Gemalto is now part of the Thales Group, find out more.

You are here

BG2 with pppd hang-ups | Thales IoT Developer Community

March 13, 2015 - 4:21pm, 2265 views

Hi everybody,


i was observing a strange effect. We have about 25 BG2 modems in field. The host is a linux system running pppd (version 2.4.5). The modem should be always connected; the pppd is configured with persistent (see below my configurations).

We have got recently some complains from the field, that the communication stops working and only disconnecting the modem from the power supply and connecting it back readable the communication. This happens sometime once a month, sometime 2-4 ***** a week.

I have analyzed the pppd log and found out that the modem dose not answer at a certain point in time:

- The LCP Echo Req is not answered anymore 

- pppd try to redial, but the modem dose not answer the AT commands any more

Did anybody face a similar problem?

My pppd options:

==================

noauth

ttyS1 115200

debug

name test

connect  "/usr/sbin/chat -vf /etc/chatscripts/icb"

novj

asyncmap 0xa0000

defaultroute

replacedefaultroute

usepeerdns

persist

holdoff 120

maxfail 0

lcp-echo-interval 120

lcp-echo-failure 3

=======================================

The chatscript :

=======================================

ABORT     'BUSY'

ABORT     'NO CARRIER'

''    AT\^SCKS?

OK    AT+CPIN?

OK    ATZ

OK    AT+CREG?

OK    AT+CSQ

OK    AT+CIMI

OK    AT+CGATT=0

OK    AT+CGDCONT=1,"IP","m2m.cda.vodafone.de"

OK    AT+CGATT=1

OK    ATE0V1

OK    ATDT*99***1#

CONNECT    ''

====================================

Thanks for you help,

Serj