Gemalto is now part of the Thales Group, find out more.

You are here

Accessing the GPIO ports on the EHS6T [Solved] | Thales IoT Developer Community

September 2, 2015 - 5:00pm, 4119 views

Hi, I'm currently in the middle of a simple SMS application using AT commands controlled via a C# program.. Then eventually embedded into Java.

The problem I am having is that non of the GPIO ports cannot be accessed as inputs or outputs. I don't recieve any errors when inputting the AT^SCPIN commands. The set and get commands do not match the hardware conditions.

For example:
  GPIO6 as an input (AT^SCPIN=1,6,0) tied to 5V (pin 7) will return (AT^SGIO=6) 0.
  GPIO8 set as an active high output (AT^SCPIN=1,8,1,1) will return (AT^SGIO=8) 1 even though the pin is measured at 0v or floating.

I've tried bridging pins 1 and 7 but it makes little to no difference. The module is as it came from the factory with no running programs on, besides the MIDIlet suite . Is there any initialisation command that I am missing out on or something?

Any help would be greatly appreciated, thanks!