Gemalto is now part of the Thales Group, find out more.

You are here

EHS8 unit does not output GPS | Thales IoT Developer Community

March 15, 2017 - 4:57pm, 2069 views

I have an EHS8 ****m and the GPS line is not outputting any data.  All of the SGPSC commands return Error.

I have cellular connection through the ****m - just no GPS.

I have tried factory reset AT&F, AT+CFUN=1,1

Am I missing something obvious?  This is the only EHS8 module I cannot get to output the GPS.

Further Info:

AT^SGPSC=? returns 'Error'

AT^SGPSC? returns 'Error'

AT^SCFG returns:

^SCFG: "Audio/Loop","0"
^SCFG: "Call/ECC","0"
^SCFG: "Call/Speech/Codec","0"
^SCFG: "Gpio/****/ASC1","gpio"
^SCFG: "Gpio/****/DAI","gpio"
^SCFG: "Gpio/****/DCD0","gpio"
^SCFG: "Gpio/****/DSR0","gpio"
^SCFG: "Gpio/****/DTR0","gpio"
^SCFG: "Gpio/****/FSR","gpio"
^SCFG: "Gpio/****/HSIC","gpio"
^SCFG: "Gpio/****/GPSANT","gpio"
^SCFG: "Gpio/****/PULSE","gpio"
^SCFG: "Gpio/****/PWM","gpio"
^SCFG: "Gpio/****/RING0","gpio"
^SCFG: "Gpio/****/SPI","gpio"
^SCFG: "Gpio/****/SYNC","std"
^SCFG: "GPRS/AutoAttach","enabled"
^SCFG: "Ident/Manufacturer","Cinterion"
^SCFG: "Ident/Product","EHS8"
^SCFG: "MEopMode/SoR","off"
^SCFG: "MEShutdown/Fso","0"
^SCFG: "MEShutdown/sVsup/threshold","0","0"
^SCFG: "Radio/Band","511"
^SCFG: "Radio/OutputPowerReduction","4"
^SCFG: "Serial/Interface/Allocation","0","0"
^SCFG: "Serial/USB/DDD","0","0","0409","1E2D","0058","Cinterion Wireless Modules","EHx",""
^SCFG: "Tcp/IRT","3"
^SCFG: "Tcp/MR","10"
^SCFG: "Tcp/OT","6000"
^SCFG: "Tcp/WithURCs","on"
^SCFG: "Trace/Syslog/OTAP","0"
^SCFG: "Userware/Autostart","0"
^SCFG: "Userware/Autostart/Delay","0"
^SCFG: "Userware/DebugInterface","0.0.0.0","0.0.0.0","0"
^SCFG: "Userware/DebugMode","off"
^SCFG: "Userware/Passwd",
^SCFG: "Userware/Stdout","null",,,,"off"
^SCFG: "Userware/Watchdog","0"